All systems operational

Planned Downtime

Completed
Scheduled for 04 02 2024 at 3:00 AM – 04 03 2024 at 11:10 AM

Affects

Databases
Ambrosia
Olympus
Popplio
Client
Development
Updates
  • Completed
    04 03 2024 at 11:10 AM
    Completed
    04 03 2024 at 11:10 AM

    Maintenance has been completed :D

  • Update
    04 02 2024 at 11:38 PM
    In progress
    04 02 2024 at 11:38 PM

    Majority of our services are back online however we are still working on some things such as our CDN. We appreciate your patience during this time!

  • Update
    04 02 2024 at 11:28 AM
    In progress
    04 02 2024 at 11:28 AM

    We are continuing to work on some necessary changes and hope to have our services back online soon!

  • In progress
    04 02 2024 at 3:00 AM
    In progress
    04 02 2024 at 3:00 AM

    Maintenance is in progress!

  • Planned
    04 02 2024 at 3:00 AM
    Planned
    04 02 2024 at 3:00 AM

    We are planning for some downtime, please bare with us!