Scheduled for 05 29 2025 at 5:47 AM – 05 31 2025 at 8:51 PM
Completed
05 31 2025 at 8:51 PMCompleted
05 31 2025 at 8:51 PMOur team is still working hard to restore our services, at this time 90% of services have been restored and we are actively working to resolve the remaining issues.
In progress
05 29 2025 at 9:44 AMIn progress
05 29 2025 at 9:44 AMWe are still working on this maintenance and will be extending its end date!
Completed
05 29 2025 at 8:47 AMCompleted
05 29 2025 at 8:47 AMMaintenance has completed successfully
Planned
05 29 2025 at 5:47 AMPlanned
05 29 2025 at 5:47 AMOur team will be looking into the dns capabilities of our new deployment service, our services may drop randomly during this time. Please bare with us while we resolve it!
In progress
05 29 2025 at 5:47 AMIn progress
05 29 2025 at 5:47 AMMaintenance is now in progress.